linux下rpm安装,及error: Failed dependencies错

半兽人 发表于: 2017-09-21   最后更新时间: 2017-09-21  
  •   7 订阅,832 游览

在用rpm安装的时候,出现以下错误

[root@10-23-116-62 grafana]# rpm -ivh grafana-4.5.1-1.x86_64.rpm 
warning: grafana-4.5.1-1.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 24098cb6: NOKEY
error: Failed dependencies:
        urw-fonts is needed by grafana-4.5.1-1.x86_64

依赖关系非常复杂,当你试图先安装任何一个包时都会出现这样的依赖关系错误,这时候你就应该强制安装了,我认为只要你把服务或软件需要的包都装上,强制安装也不会出问题的,不会有什么影响。

非常简单,只要加上一个--force (强制) 和--nodeps(不查找依赖关系)就可以了

如:rpm -vih rpm -ivh grafana-4.5.1-1.x86_64.rpm  --force --nodeps

卸载时就不用--force了,只要加入--nodeps 就可以了。







发表于: 10月前   最后更新时间: 10月前   游览量:832
上一条: Linux路由配置详情
下一条: linxu文件权限

评论…


  • 评论…
    • in this conversation
      提问