使用bin/kafka-consumer-groups.sh --bootstrap-server * --describe --group *查询消费组信息时,报错

使用的kafka版本为1.1.0
对于某些group,使用该命令查询消费组信息正常,对于有的group报该错误

Error: Executing consumer group command failed due to Error reading field 'version': java.nio.BufferUnderflowException






发表于: 9天前   最后更新时间: 9天前   游览量:105
上一条: 到头了!
下一条: 已经是最后了!

评论…


  • 下溢,说明查询的字节最低不满足。你的命令里也带*吗?
    • 看看消费者列表包含么
      bin/kafka-consumer-groups.sh --new-consumer --bootstrap-server localhost:9092 --list

      kafka命令大全:http://orchome.com/454
      • 评论…
        • in this conversation